Lỗi: Browser KHÔNG thể hiện hình ảnh mà chỉ là DẤU CHẤM HỎI


#1

26
Mình xin cảm ơn.


#2

Hi anh @vietnguyen,

Anh nén toàn bộ code của anh (gồm cả file html và các hình ảnh) thành 1 file rồi up lên đây giúp em ạ.

Em cảm ơn anh


#3

À. Trường hợp của anh là:

  • Khi file .html và file ảnh nằm trong cùng 1 folder thì kết quả trả về hoàn toàn ok.
  • Nhưng khi anh di chuyển file ảnh và file.html vào 2 folder cùng cấp khác nhau thì nó bị lỗi như vậy.

#4

Dạ. Anh chụp hình vị trí file ảnh và file html, cùng code thẻ img của file ảnh đó ở trường hợp thứ 2, hoặc nén tất cả lại rồi up lên giúp em ạ

Vì em cần biết nơi đặt file ảnh, file html và code của anh ạ


#5

Vi%CC%80%20tri%CC%81%20a%CC%89nh%20sau%20khi%20di%20chuye%CC%82%CC%89nhtml%20sau%20khi%20di%20chuye%CC%82%CC%89n05


#6

Chào bạn, bạn bỏ dấu …/ tại đường dẫn xem kết quả hiển thị ra được không nhé


#7

Đã thử cách đó luôn nhưng vẫn không được bạn ơi. Hôm qua cũng có nhờ bộ phận hỗ trợ nhưng vẫn chưa tìm ra lỗi. hic


#8

Bạn mở trực tiếp file index.html để chạy hay là tạo server ảo để hiển thị lên vậy? (http://localhost/…)


#9

Mình mở trực tiếp bằng safari và chrome để chạy, có gì đó không ổn hả bạn


#10

Thường theo mình có một số nguyên nhân chính dẫn đến k hiển thị img:

  • Ảnh sử dụng k đáp ứng định dạng browser đòi hỏi. Cái này ít gặp.
  • Ảnh có size quá nhỏ.
  • Sai đường dẫn.
    Với trường hợp của a nên kiểm tra path lại xem. Và theo ý kiến cá nhân nên dùng chrome để test vì sau này khi a tìm hiểu sâu hơn, so với các browser khác, nó tiện, dễ nhìn, dễ thao tác và thông minh hơn.

#11

:slight_smile: mình xin nhận góp ý của bạn. Cảm ơn bạn nhe!